Full publish dialog

Can someone please help with this? It’s not a blocker but I’d like too understand it.

I worked several days in the solution and published it numerous times. But now when I tried to publish again and get this message “there are changes in the solution that require the whole application to be redeployed”, etc. I was able to publish after clicking through the dialog. But why did this happen? It’s a nuisance to do this each time.

Full publish

Good morning Ines! Usually you will not see the “full deployment” dialog when publishing your solution.

In general it pops up under these circumstances:

  1. First publish

  2. Adding, removing or replacing resource files:If you navigate to the Solution tab, then Resources -> File you can see where this is done. Any changes made here will force a full publish, because the files must also be distributed onto the server. Note: this could also happen if you import one of our pre-built solutions that adds a resource under File.

If this doesn’t explain what happened, please supply more information and I’ll try and look deeper.

Kind regards, Fred

Thanks! That explains it - I added some jar files I needed for scripting.