Error when pushing a stable version

I have an issue when I try to push a stable version to QA, and I can’t find any info on this topic anywhere.
So I get this error message and I don’t understand why it won’t work.
I will also just say I have only ever gotten this to work ONE time before, and it was 5 minutes before it failed again. And I’ve been trying this for a few months…

I back tracked my steps and reverted to the same unstable tick on the flows and global variables i changed but I guess I just got lucky and it worked one time.

Please let me know if anyones had the same and how they fixed it.
Regards, Roxanne

Hi Roxanne,

Let me ask you some questions so we can try to find the reason for the failure.

I understand that the solution is running without errors when you use Tryout for developing. Did you try to switch to Stable in Tryout to see if that also works?

Are you aware of what changed between the time it worked for you and the subsequent failure?

Have you confirmed that all required elements are included in the Stable version, and that the Stable documents do not have dependencies on documents that have not been marked as Stable?

Also, did you request the webapplication server log files as suggested in the error message to see what additional information they could provide?